Azure has confirmed that services have recovered, and we have also observed system recovery.
Posted May 29, 2026 - 23:19 UTC
Update
We continue to monitor the ongoing Azure infrastructure issue impacting the WestUs2 region. At this time, customers may still experience degraded performance or error state and inconsistencies in observability, including delayed metrics or reduced visibility into system behavior. Azure has not yet confirmed full recovery for the affected region, and we remain engaged in monitoring the impact on our platform.
Posted May 29, 2026 - 07:46 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 29, 2026 - 05:55 UTC
Investigating
We are currently observing potential issues in the Azure us west 2 region that may be impacting system performance. This could be contributing to degraded performance or error state and inconsistencies in observability, including delayed metrics or reduced visibility into system behavior. Issue stems from Azure cloud provider.