Issue terminating a database sharing a Private Link/Private Service Connect with another database
Incident Report for DataStax Astra
Resolved
We have deployed a fix for the issue affecting Private Service Connect (GCP) and Private Link (AWS/Azure) configurations when terminating databases.
You can now safely terminate databases without impacting private link connectivity.
Posted Sep 26, 2024 - 15:15 PDT
Identified
We have identified a problem related to terminating Serverless and Classic databases that are configured with Private Service Connect (GCP) or Private Link (AWS/Azure) and are sharing the connection with another database. When one of the databases sharing the Private Link/Private Serve Connect is terminated, it causes the associated Private Service Connect or Private Link configurations to be deleted even though the connection is in use by another database.

Do not terminate your database if you are sharing a Private Link/Private Serve Connect across databases. We are currently working on a fix for this issue.
Posted Sep 26, 2024 - 11:09 PDT
This incident affected: Astra (Astra Classic DB, Astra Serverless DB).