Degraded performance on Astra Serverless databases in AWS us-west-2

Incident Report for DataStax Astra

Resolved

This incident has been resolved.
Posted Nov 04, 2025 - 15:03 UTC

Monitoring

Request errors affecting databases in the AWS us-west-2 region have recovered. Our team is continuing to monitor the situation to ensure stability.
Posted Nov 04, 2025 - 09:17 UTC

Investigating

We are currently investigating request errors affecting databases in the AWS us-west-2 region. Our team is actively working to identify the cause and will provide an update as soon as more information is available
Posted Nov 04, 2025 - 08:50 UTC
This incident affected: AWS (AWS us-west-2).