Degraded performance due to AWS issues in US-EAST-1 Region

Incident Report for DataStax Astra

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 02:30 UTC

Update

All services should be restored and we're actively monitoring the situation
Posted Oct 20, 2025 - 13:04 UTC

Monitoring

We're aware of ongoing issues in AWS which are impacting services in us-east1. Customers may see issues with databases in this region, and with database operations globally (e.g. create, hibernate, change settings).
Posted Oct 20, 2025 - 09:56 UTC
This incident affected: AWS (AWS us-east-2, AWS us-west-2, AWS us-west-1, AWS sa-east-1, AWS us-east-1, AWS eu-west-1, AWS us-east-2, ap-southeast-2), GCP (Google Cloud Platform Identity & Security, Google Cloud Platform Google Stackdriver, Google Cloud Platform Identity & Access Management, Google Cloud Platform Google Cloud DNS, Google Cloud Platform Google Cloud Storage, Google Cloud Platform Google Kubernetes Engine, Google Cloud Platform Google Cloud Networking), Astra (Astra Portal, Astra Classic DB, Astra Serverless DB, Astra Streaming), and Azure (westus2, eastus2, westeurope, australiaeast, canadacentral, centralindia, westus3, northeurope, eastus, brazilsouth, centralus).