New Database Creation Astra Managed Clusters Failing in AWS

Incident Report for DataStax Astra

Resolved

AWS has rolled back changes to their EKS API servers which introduced some incompatibility causing our client API calls to fail. This incident is now resolved and database creation for AWS Astra Managed Clusters is working in all available regions.
Posted Jan 14, 2026 - 20:28 UTC

Investigating

Database creation for Astra Managed Clusters, formerly known as Astra Classic, is failing in AWS. GCP and Azure are unaffected. All traffic to existing Astra Managed Cluster databases are unaffected.

Astra Serverless database creations are unaffected by this incident.
Posted Jan 14, 2026 - 17:47 UTC
This incident affected: Astra (Astra Classic DB).