Vector Database Creation Failure in AWS us-east-2

Incident Report for DataStax Astra

Resolved

This incident has been resolved.
Posted May 23, 2025 - 04:24 UTC

Monitoring

A fix has been implemented, and we are observing improvements in database creation. We are actively monitoring the situation.
Posted May 23, 2025 - 03:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 23, 2025 - 03:10 UTC

Investigating

We are currently investigating an issue with database creation in AWS us-east-2 region. No impact on existing databases.
Posted May 23, 2025 - 03:05 UTC
This incident affected: AWS (AWS us-east-2) and Astra (Astra Serverless DB).