Possibility of elevated latencies
Incident Report for DataStax Astra
Resolved
This incident is resolved.

Note: The incident was accidentally titled incorrectly. It's been updated to reflect an accurate description of the incident. There was no issue observed with elevated API errors as the original title suggested.
Posted May 21, 2024 - 14:24 PDT
Monitoring
Issue has been resolved. Latencies should now be normal for customers that may have experienced them. We are monitoring our services before we mark this "resolved"
Posted May 21, 2024 - 14:10 PDT
Investigating
We are currently investigating possible increases in latency on the us-west-2 AWS region. Some customers may experience elevated latency. We are monitoring for any change and investigating the issue further.
Posted May 21, 2024 - 13:26 PDT
This incident affected: AWS (AWS ec2-us-west-2).