Elevated request error rates in AWS eu-west-1 for Astra Serverless

Incident Report for DataStax Astra

Resolved

This incident has been resolved.
Posted May 20, 2025 - 12:26 UTC

Update

We are continuing to monitor for any further issues.
Posted May 20, 2025 - 12:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 20, 2025 - 11:45 UTC

Update

Our investigation is still ongoing and our team continues to work diligently toward resolving the issue.
Posted May 20, 2025 - 11:12 UTC

Update

We are actively working towards a resolution. Our team remains fully engaged, and we’ll share updates as progress is made.
Posted May 20, 2025 - 09:12 UTC

Identified

We have identified the issue and are taking mitigating actions
Posted May 20, 2025 - 08:14 UTC
This incident affected: Astra (Astra Serverless DB) and AWS (AWS eu-west-1).