Connection Issue Affecting US East Region

Incident Report for DataStax Astra

Postmortem

The issue is resolved, but in case you still have trouble connecting, we recommend restarting the apps.

Posted Apr 16, 2026 - 05:39 UTC

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 05:34 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2026 - 05:04 UTC

Investigating

AstraDB Service Connectivity Degradation in US East Region
Posted Apr 16, 2026 - 03:44 UTC