Degraded Performance in Azure WestEurope for Astra Serverless Databases

Incident Report for DataStax Astra

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 09:34 UTC

Monitoring

We’ve observed continued improvement in error rates and system responsiveness. A fix has been implemented, and we are now closely monitoring the system to ensure that service remains stable.
Posted Jun 24, 2025 - 08:25 UTC

Identified

We’ve observed a significant drop in error rates and improvement in overall system responsiveness. This indicates partial recovery, but we are still actively working to confirm full service stability. Our engineering team continues to investigate the underlying cause and is closely monitoring the situation.
Posted Jun 24, 2025 - 08:21 UTC

Investigating

We are currently investigating an issue affecting Astra DB Serverless databases in the Azure WestEurope region. Customers may experience degraded performance, elevated latencies, or intermittent timeouts when accessing their databases in this region.
Posted Jun 24, 2025 - 05:01 UTC
This incident affected: Azure (westeurope).